summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:39:34 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:20 +0200
commit0f5f9eacf40ff560101b5bac002022560dd14d73 (patch)
tree64e743940e966cdf689205479c3f939185d5ec2d /gnu
parent8d7f5c55a7bb67162f6dac64ed8948f939f27f0e (diff)
downloadpatches-0f5f9eacf40ff560101b5bac002022560dd14d73.tar
patches-0f5f9eacf40ff560101b5bac002022560dd14d73.tar.gz
gnu: emacs-f3: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-f3)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6577cb7aed..a3584a451b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10654,13 +10654,13 @@ buffer with each of your todos.")
(version "0.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/cosmicexplorer/f3/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cosmicexplorer/f3.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "06b8i1jvklm5k3k90n65f197l1miq1xlxqkqpbppw4h3rhl4y98h"))))
+ (base32 "1qg48zbjdjqimw4516ymrsilz41zkib9321q0caf9474s9xyp2bi"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-helm" ,emacs-helm)))