summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-09-30 14:08:42 -0400
committerLeo Famulari <leo@famulari.name>2018-09-30 14:09:48 -0400
commitf2bc53af70eea7b7147b9e7e40280941866ed128 (patch)
treeeda411585616d9600f5e415a7e0a4f8dc9c7360a /gnu
parentcebec8bd1ca3871dead210c2e8404e3f5cec8ab7 (diff)
downloadpatches-f2bc53af70eea7b7147b9e7e40280941866ed128.tar
patches-f2bc53af70eea7b7147b9e7e40280941866ed128.tar.gz
gnu: Add porechop.
* gnu/packages/bioinformatics.scm (porechop): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e74abf005f..b84498d042 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13869,3 +13869,33 @@ single-cell transcriptomic map of the human and mouse pancreas reveals inter-
and intra-cell population structure.\" Baron et al. Cell Systems (2016)
@url{https://www.ncbi.nlm.nih.gov/pubmed/27667365}.")
(license license:gpl2+))))
+
+(define-public porechop
+ ;; The recommended way to install is to clone the git repository
+ ;; https://github.com/rrwick/Porechop#installation
+ (let ((commit "289d5dca4a5fc327f97b3f8cecb68ecaf1014861")
+ (revision "1"))
+ (package
+ (name "porechop")
+ (version (git-version "0.2.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rrwick/Porechop.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05ps43gig0d3ia9x5lj84lb00hbsl6ba9n7y7jz927npxbr2ym23"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/rrwick/porechop")
+ (synopsis "Finding, trimming or splitting adapters, in Oxford Nanopore reads")
+ (description
+ "The porechop package is a tool for finding and removing adapters from Oxford
+Nanopore reads. Adapters on the ends of reads are trimmed off, and when a read
+has an adapter in its middle, it is treated as chimeric and chopped into
+separate reads. Porechop performs thorough alignments to effectively find
+adapters, even at low sequence identity. Porechop also supports demultiplexing
+of Nanopore reads that were barcoded with the Native Barcoding Kit, PCR
+Barcoding Kit or Rapid Barcoding Kit.")
+ (license license:gpl3+))))