summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-07-04 17:43:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-07-05 15:08:44 +0200
commitfa6975996384c8ae1287f8673a59bda3d86a1532 (patch)
tree88731b4f241eceed016f248970cf7843160a3591 /gnu
parent3629622bc8b77f240ec62a982e453dc8885890b2 (diff)
downloadpatches-fa6975996384c8ae1287f8673a59bda3d86a1532.tar
patches-fa6975996384c8ae1287f8673a59bda3d86a1532.tar.gz
gnu: Add r-argparse.
* gnu/packages/cran.scm (r-argparse): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9f4c640753..fc4baa5b54 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4619,3 +4619,30 @@ support for default values, positional argument support, etc.")
"This package was designed to find an acceptable Python binary that
matches version and feature constraints.")
(license license:expat)))
+
+;; This in not the same as "r-argparser"
+(define-public r-argparse
+ (package
+ (name "r-argparse")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "argparse" version))
+ (sha256
+ (base32
+ "0fzrbj87b274vf96azdnsjxk2nf45d5wy58vzmlah4b4h7q4j524"))))
+ (build-system r-build-system)
+ (inputs `(("python" ,python)))
+ (propagated-inputs
+ `(("r-findpython" ,r-findpython)
+ ("r-getopt" ,r-getopt)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-proto" ,r-proto)))
+ (home-page "https://github.com/trevorld/argparse")
+ (synopsis "Command line optional and positional argument parser")
+ (description
+ "This package provides a command line parser to be used with Rscript to
+write shebang scripts that gracefully accept positional and optional arguments
+and automatically generate usage notices.")
+ (license license:gpl2+)))