summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-08-24 18:33:43 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-09-01 11:14:16 +0530
commitf618086220106a15842fce9b4cbe1525a1473f42 (patch)
tree23464b023abdc8f203aa813ad7cf3d346be3b765 /gnu
parent689042e5260c6e2ce6190115e9025f49fc8c6b6d (diff)
downloadpatches-f618086220106a15842fce9b4cbe1525a1473f42.tar
patches-f618086220106a15842fce9b4cbe1525a1473f42.tar.gz
gnu: python2-ttystatus: Enable tests.
* gnu/packages/python.scm (python2-ttystatus)[arguments]: Replace 'check' phase with custom function.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0687a23bc4..8bdd865af3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14133,8 +14133,20 @@ iterating over input files.")
(base32
"0vivqbw7ddhsq1zj3g9cvvv4f0phl0pis2smsnwcr2szz2fk3hl6"))))
(build-system python-build-system)
+ (native-inputs
+ `(("python2-coverage-test-runner" ,python2-coverage-test-runner)
+ ("python2-pep8" ,python2-pep8)))
(arguments
- `(#:python ,python-2))
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ ;; check phase needs to be run before the build phase. If not,
+ ;; coverage-test-runner looks for tests for the built source files,
+ ;; and fails.
+ (delete 'check)
+ (add-before 'build 'check
+ (lambda _
+ (zero? (system* "make" "check")))))))
(home-page "https://liw.fi/ttystatus/")
(synopsis "Python library for showing progress reporting and
status updates on terminals")