summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-09 16:09:13 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:24 +0100
commiteee5cd04405dc499fcdce20f9219a9bded5720ce (patch)
tree96b60136a83f4a4f2fec5b5faad042bde748d2e5 /gnu
parentd548e6aa06702793471ae764bd4df3265dbcfb7f (diff)
downloadpatches-eee5cd04405dc499fcdce20f9219a9bded5720ce.tar
patches-eee5cd04405dc499fcdce20f9219a9bded5720ce.tar.gz
gnu: python-ipython: Fix build.
* gnu/packages/python.scm (python-ipython, python2-ipython) [check, install-doc] set PYTHONPATH prior to running tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e0d0843839..a3fd374a6f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4664,6 +4664,8 @@ tools for mocking system commands and recording calls to those.")
(info (string-append data "/info"))
(examples (string-append doc "/examples")))
(setenv "LANG" "en_US.utf8")
+ ;; Make installed package available for running the tests
+ (add-installed-pythonpath inputs outputs)
(with-directory-excursion "docs"
;; FIXME: pdf fails to build
;;(system* "make" "pdf" "PAPER=a4")
@@ -4683,9 +4685,11 @@ tools for mocking system commands and recording calls to those.")
(delete 'check)
(add-after
'install 'check
- (lambda* (#:key outputs tests? #:allow-other-keys)
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
(if tests?
(with-directory-excursion "/tmp"
+ ;; Make installed package available for running the tests
+ (add-installed-pythonpath inputs outputs)
(setenv "HOME" "/tmp/") ;; required by a test
(zero? (system* (string-append (assoc-ref outputs "out")
"/bin/iptest"))))