summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-03-14 19:34:22 -0400
committerLeo Famulari <leo@famulari.name>2016-03-24 15:30:51 -0400
commitbd74be7b8c6f3df34d8556f55ab9ef7411c07933 (patch)
tree56699aa3fc4aae72f5b26c845fecea54594a755d /gnu
parentae831df428e5c782906d19c8c270350cbbf070ac (diff)
downloadpatches-bd74be7b8c6f3df34d8556f55ab9ef7411c07933.tar
patches-bd74be7b8c6f3df34d8556f55ab9ef7411c07933.tar.gz
gnu: python-msgpack: Use 'python2-variant'.
* gnu/packages/python.scm (python-msgpack)[native-inputs]: Remove field. [properties]: New field. (python2-msgpack): Use 'strip-python2-variant'. [native-inputs]: Add python2-setuptools.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 24eca007eb..0ac7c06eaf 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5425,14 +5425,19 @@ should be stored on various operating systems.")
(base32
"0syd7bs83qs9qmxw540jbgsildbqk4yb57fmrlns1021llli402y"))))
(build-system python-build-system)
- (native-inputs
- `(("python-setuptools" ,python-setuptools)))
(synopsis "MessagePack (de)serializer")
(description "MessagePack is a fast, compact binary serialization format,
suitable for similar data to JSON. This package provides CPython bindings for
reading and writing MessagePack data.")
(home-page "https://pypi.python.org/pypi/msgpack-python/")
- (license asl2.0)))
+ (license asl2.0)
+ (properties `((python2-variant . ,(delay python2-msgpack))))))
+
+(define-public python2-msgpack
+ (package (inherit (package-with-python2
+ (strip-python2-variant python-msgpack)))
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)))))
(define-public python2-msgpack
(package-with-python2 python-msgpack))