summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-09 04:49:59 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:38 -0500
commitab41f9799f962a4c7f90aa82deb11fda4ad03167 (patch)
tree18df892f91f188ba8a743cb8b44db71db4992dc4 /gnu
parent79e8a2916dac8bea5fcaabf257ed86d2bfd5daff (diff)
downloadpatches-ab41f9799f962a4c7f90aa82deb11fda4ad03167.tar
patches-ab41f9799f962a4c7f90aa82deb11fda4ad03167.tar.gz
gnu: Add python-ndg-httpsclient.
* gnu/packages/python.scm (python-ndg-httpsclient, python2-ndg-httpsclient): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ff37b865a9..4d0c23d1ee 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6489,3 +6489,35 @@ be set via config files and/or environment variables.")
(define-public python2-configargparse
(package-with-python2 python-configargparse))
+
+(define-public python-ndg-httpsclient
+ (package
+ (name "python-ndg-httpsclient")
+ (version "0.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/n/ndg-httpsclient/"
+ "ndg_httpsclient-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0x32ibixm3vv5m9xfk83xsqm8xcqw4dd0khbh6qbri6rxgymbhg8"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pyopenssl" ,python-pyopenssl)))
+ (synopsis "HTTPS support for Python's httplib and urllib2")
+ (description "This is a HTTPS client implementation for httplib and urllib2
+based on PyOpenSSL. PyOpenSSL provides a more fully featured SSL implementation
+over the default provided with Python and importantly enables full verification
+of the SSL peer.")
+ (home-page "https://github.com/cedadev/ndg_httpsclient/")
+ (license bsd-3)))
+
+;; python2-openssl requires special care, so package-with-python2 is
+;; insufficient.
+(define-public python2-ndg-httpsclient
+ (package (inherit python-ndg-httpsclient)
+ (name "python2-ndg-httpsclient")
+ (arguments `(#:python ,python-2))
+ (propagated-inputs
+ `(("python2-pyopenssl" ,python2-pyopenssl)))))