summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-08 22:00:40 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:36 -0500
commit81f2373cd4f3a6c4992573d9cacd0ff57b63ffd2 (patch)
treec88fc53ab58ebde28addaaf017216737ea94939c /gnu
parent97abe268ab54c2aa6aad9b9e068ace9f8ab87988 (diff)
downloadpatches-81f2373cd4f3a6c4992573d9cacd0ff57b63ffd2.tar
patches-81f2373cd4f3a6c4992573d9cacd0ff57b63ffd2.tar.gz
gnu: Add python-zope-exceptions.
* gnu/packages/python.scm (python-zope-exceptions, python2-zope-exceptions): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fbefd9598f..0aabe083ea 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6059,3 +6059,30 @@ conforming to a given API or contract.")
(define-public python2-zope-interface
(package-with-python2 python-zope-interface))
+
+(define-public python-zope-exceptions
+ (package
+ (name "python-zope-exceptions")
+ (version "4.0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/z"
+ "/zope.exceptions/zope.exceptions-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0zwxaaa66sqxg5k7zcrvs0fbg9ym1njnxnr28dfmchzhwjvwnfzl"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; circular dependency with zope.testrunner
+ (propagated-inputs
+ `(("python-zope-interface" ,python-zope-interface)))
+ (home-page "http://cheeseshop.python.org/pypi/zope.exceptions")
+ (synopsis "Zope exceptions")
+ (description "Zope.exceptions provides general-purpose exception types
+that have uses outside of the Zope framework.")
+ (license zpl2.1)))
+
+(define-public python2-zope-exceptions
+ (package-with-python2 python-zope-exceptions))