summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-08 22:03:22 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:36 -0500
commit71fb09f32633bdf36151a10ea25b68409587f25f (patch)
tree8420a2d0e3f99f8a5403c334b78bef1f34b8c07e /gnu
parent6a5c710c40c147c90af61afc3a8d693844d0f83e (diff)
downloadpatches-71fb09f32633bdf36151a10ea25b68409587f25f.tar
patches-71fb09f32633bdf36151a10ea25b68409587f25f.tar.gz
gnu: Add python-zope-schema.
* gnu/packages/python.scm (python-zope-schema, python2-zope-schema): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4707a5c032..81c10fb008 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6174,3 +6174,30 @@ internationalized messages within program source text.")
(define-public python2-zope-i18nmessageid
(package-with-python2 python-zope-i18nmessageid))
+
+(define-public python-zope-schema
+ (package
+ (name "python-zope-schema")
+ (version "4.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/z"
+ "/zope.schema/zope.schema-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1p943jdxb587dh7php4vx04qvn7b2877hr4qs5zyckvp5afhhank"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-zope-event" ,python-zope-event)
+ ("python-zope-interface" ,python-zope-interface)))
+ (native-inputs
+ `(("python-zope-testing" ,python-zope-testing)))
+ (home-page "http://pypi.python.org/pypi/zope.schema")
+ (synopsis "Zope data schemas")
+ (description "Zope.scheme provides extensions to zope.interface for
+defining data schemas.")
+ (license zpl2.1)))
+
+(define-public python2-zope-schema
+ (package-with-python2 python-zope-schema))