summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-09 15:40:14 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-09 23:53:36 +0200
commit6f05630ba6848fa666f4ea57aab7f7ffbc15fc72 (patch)
treebcff6abefe3edb24289fffb095b4cd4409526388 /gnu
parent15f0de0581987c539f86012bf524559e283f5942 (diff)
downloadpatches-6f05630ba6848fa666f4ea57aab7f7ffbc15fc72.tar
patches-6f05630ba6848fa666f4ea57aab7f7ffbc15fc72.tar.gz
gnu: wicd: Add patch to fix template instantiation.
* gnu/packages/patches/wicd-template-instantiation.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/wicd.scm (wicd)[source]: Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/wicd-template-instantiation.patch29
-rw-r--r--gnu/packages/wicd.scm4
2 files changed, 32 insertions, 1 deletions
diff --git a/gnu/packages/patches/wicd-template-instantiation.patch b/gnu/packages/patches/wicd-template-instantiation.patch
new file mode 100644
index 0000000000..16d8fa6e1d
--- /dev/null
+++ b/gnu/packages/patches/wicd-template-instantiation.patch
@@ -0,0 +1,29 @@
+Wicd 1.7.3 fails to instantiate template lines that have several
+variable references. For instance, the line:
+
+ wep_key$_KEY_INDEX=$_KEY
+
+which is found in in the 'wep-hex' template, expands to these two
+lines:
+
+ wep_key0=$_KEY
+ wep_key0=123456789ab
+
+This patch fixes that by only emitting the fully substituted line.
+
+Patch by Ludovic Courtès <ludo@gnu.org>.
+
+--- a/wicd/misc.py 2012-11-17 00:07:08 +0000
++++ b/wicd/misc.py 2015-05-09 11:22:37 +0000
+@@ -321,11 +321,11 @@ def ParseEncryption(network):
+ rep_val = '0'
+ if rep_val:
+ line = line.replace("$_%s" % cur_val, str(rep_val))
+- config_file = ''.join([config_file, line])
+ else:
+ print "Ignoring template line: '%s'" % line
+ else:
+ print "Weird parsing error occurred"
++ config_file = ''.join([config_file, line])
+ else: # Just a regular entry.
+ config_file = ''.join([config_file, line])
diff --git a/gnu/packages/wicd.scm b/gnu/packages/wicd.scm
index 1953a56b6c..779ec84e3c 100644
--- a/gnu/packages/wicd.scm
+++ b/gnu/packages/wicd.scm
@@ -44,7 +44,9 @@
"/+download/wicd-" version ".tar.gz"))
(sha256
(base32 "00c4rq753bhg64rv1v9yl834ssq7igyy7cz3swp287b5n5bqiqwi"))
- (patches (list (search-patch "wicd-urwid-1.3.patch")))))
+ (patches (map search-patch
+ '("wicd-urwid-1.3.patch"
+ "wicd-template-instantiation.patch")))))
(build-system python-build-system)
(native-inputs `(("gettext" ,gnu-gettext)))
(inputs `(("dbus" ,dbus)