summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-07-04 17:41:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-07-05 15:08:44 +0200
commit64abd24517acbc43daf13bbdb1f73f547649c90b (patch)
treea5913b9cef63b473fae1854612e069f2810809a7 /gnu
parent0a562e46ff3be3e6d219f9dab08ae16539d12d26 (diff)
downloadpatches-64abd24517acbc43daf13bbdb1f73f547649c90b.tar
patches-64abd24517acbc43daf13bbdb1f73f547649c90b.tar.gz
gnu: Add r-biasedurn.
* gnu/packages/cran.scm (r-biasedurn): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f4a794a54a..77f27c35bd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4523,3 +4523,26 @@ patterned after functions in the snow package.")
"This package provides a data frame to xlsx exporter based on
libxlsxwriter.")
(license license:bsd-2)))
+
+(define-public r-biasedurn
+ (package
+ (name "r-biasedurn")
+ (version "1.07")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "BiasedUrn" version))
+ (sha256
+ (base32
+ "13i2lgfnjhlbbm2yxfc2l5hswqw6x03pwba5csjmirv8kpjw4xr3"))))
+ (properties `((upstream-name . "BiasedUrn")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/BiasedUrn/")
+ (synopsis "Biased Urn model distributions")
+ (description
+ "This package provides statistical models of biased sampling in the form
+of univariate and multivariate noncentral hypergeometric distributions,
+including Wallenius' noncentral hypergeometric distribution and Fisher's
+noncentral hypergeometric distribution (also called extended hypergeometric
+distribution).")
+ (license license:gpl3)))