summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-08 21:58:16 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:36 -0500
commit2fc5f186801ab8e989b6d8e97f37455af96969fd (patch)
tree635d39f5dbb60ab1517bff446dff27c60f566fcc /gnu
parent6bad7524a6dba18f700893953584ad8865b18729 (diff)
downloadpatches-2fc5f186801ab8e989b6d8e97f37455af96969fd.tar
patches-2fc5f186801ab8e989b6d8e97f37455af96969fd.tar.gz
gnu: Add python-zope-event.
* gnu/packages/python.scm (python-zope-event, python2-zope-event): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3385393f1b..25f5c6eeeb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
+;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015 Erik Edrosa <erik.edrosa@gmail.com>
@@ -6006,3 +6007,29 @@ automatically detect a wide range of file encodings.")
(define-public python2-chardet
(package-with-python2 python-chardet))
+
+(define-public python-zope-event
+ (package
+ (name "python-zope-event")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/z"
+ "/zope.event/zope.event-" version ".tar.gz"))
+ (sha256
+ (base32
+ "11p75zpfz3ffhz21nzx9wb23xs993ck5s6hkjcvhswwizni5jynw"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://pypi.python.org/pypi/zope.event")
+ (synopsis "Event publishing system for Python")
+ (description "Zope.event provides an event publishing API, intended for
+use by applications which are unaware of any subscribers to their events. It
+is a simple event-dispatching system on which more sophisticated event
+dispatching systems can be built.")
+ (license zpl2.1)))
+
+(define-public python2-zope-event
+ (package-with-python2 python-zope-event))