summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2015-12-05 02:11:31 -0500
committerLudovic Courtès <ludo@gnu.org>2015-12-06 22:38:32 +0100
commit1872f1bb798d399a9fb7affc375af1581fabf5a2 (patch)
tree090d5ba80c75434cb5bc041c81d9d9de33eb396f /gnu
parent07ab3b8eccc3b35faa010d0916d346caa0d3e62c (diff)
downloadpatches-1872f1bb798d399a9fb7affc375af1581fabf5a2.tar
patches-1872f1bb798d399a9fb7affc375af1581fabf5a2.tar.gz
gnu: Add python-docopt.
* gnu/packages/python.scm (python-docopt, python2-docopt): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7d54516206..056775ec40 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2015 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015 Erik Edrosa <erik.edrosa@gmail.com>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015 Kyle Meyer <kyle@kyleam.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6010,6 +6011,41 @@ automatically detect a wide range of file encodings.")
(define-public python2-chardet
(package-with-python2 python-chardet))
+(define-public python-docopt
+ (package
+ (name "python-docopt")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ ;; The release on PyPI does not include tests.
+ (uri (string-append
+ "https://github.com/docopt/docopt/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "16bf890xbdz3m30rsv2qacklh2rdn1zrfspfnwzx9g7vwz8yw4r1"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-setuptools" ,python-setuptools)))
+ (arguments
+ `(#:phases (alist-replace
+ 'check
+ (lambda _ (zero? (system* "py.test")))
+ %standard-phases)))
+ (home-page "http://docopt.org")
+ (synopsis "Command-line interface description language for Python")
+ (description "This library allows the user to define a command-line
+interface from a program's help message rather than specifying it
+programatically with command-line parsers like @code{getopt} and
+@code{argparse}.")
+ (license license:expat)))
+
+(define-public python2-docopt
+ (package-with-python2 python-docopt))
+
(define-public python-zope-event
(package
(name "python-zope-event")