summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-12-07 12:31:56 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-12-07 12:31:56 +0200
commit044176621e80eaf7c97cf92a5ea6cf97bd7dd45a (patch)
treef4973e315b7d9b263151f0236c863e31b2f0a17f /gnu
parentb847618f65a5365ebc317ce3cb3a07dacb529d41 (diff)
downloadpatches-044176621e80eaf7c97cf92a5ea6cf97bd7dd45a.tar
patches-044176621e80eaf7c97cf92a5ea6cf97bd7dd45a.tar.gz
gnu: python2-zope-security: Use python2-zope-testrunner.
* gnu/packages/python.scm (python2-zope-security): Do it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 056775ec40..d01c1d3df1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6345,7 +6345,13 @@ security policies on Python objects.")
(license zpl2.1)))
(define-public python2-zope-security
- (package-with-python2 python-zope-security))
+ (let ((zope-security (package-with-python2 python-zope-security)))
+ (package (inherit zope-security)
+ (propagated-inputs
+ `(("python2-zope-testrunner" ,python2-zope-testrunner)
+ ,@(alist-delete
+ "python-zope-testrunner"
+ (package-propagated-inputs zope-security)))))))
(define-public python-zope-component
(package