summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-04-30 21:23:29 +0200
committerAndreas Enge <andreas@enge.fr>2015-04-30 21:23:29 +0200
commitcfaf863f15fca75b6c2cc81ae61d8c54ecd7cf28 (patch)
tree6ebfd36fe2f8244f8fb61a31c02e8fec8b4bf04d /gnu
parent372cf03981fea2e8f95be88c8a986f996c812d14 (diff)
downloadpatches-cfaf863f15fca75b6c2cc81ae61d8c54ecd7cf28.tar
patches-cfaf863f15fca75b6c2cc81ae61d8c54ecd7cf28.tar.gz
gnu: Add orcus.
* gnu/packages/libreoffice.scm (orcus): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/libreoffice.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 97b464d0bc..cbe1c75eeb 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -23,6 +23,7 @@
#:use-module ((guix licenses) #:select (mpl2.0))
#:use-module (guix build-system gnu)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python))
@@ -50,3 +51,31 @@ expressions stored in multiple named targets, or \"cells\". The cells can
be referenced from each other, and the library takes care of resolving
their dependencies automatically upon calculation.")
(license mpl2.0)))
+
+(define-public orcus
+ (package
+ (name "orcus")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://kohei.us/files/" name "/src/lib"
+ name "-" version ".tar.xz"))
+ (sha256 (base32
+ "0hva4qalg3dk6n1118ncr5fy8cqnj2f7fwldw7aa04124rj6p104"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ixion" ,ixion)
+ ("mdds" ,mdds)
+ ("zlib" ,zlib)))
+ (home-page "https://gitlab.com/orcus/orcus")
+ (synopsis "File import filter library for spreadsheet documents")
+ (description "Orcus is a library that provides a collection of standalone
+file processing filters. It is currently focused on providing filters for
+spreadsheet documents. The library includes import filters for
+Microsoft Excel 2007 XML, Microsoft Excel 2003 XML, Open Document Spreadsheet,
+Plain Text, Gnumeric XML, Generic XML. It also includes low-level parsers for
+CSV, CSS and XML.")
+ (license mpl2.0)))