summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-06-27 19:52:54 -0400
committerMark H Weaver <mhw@netris.org>2018-11-14 23:44:18 -0500
commit2e0f69057a58a5cf2abb2f2b2c8d1a705d297c25 (patch)
tree952e27d460b8268b66b0548bc36baf8ab7c99063 /gnu
parent96272e2822046519e9d6a89bfac0d29936ef2766 (diff)
downloadpatches-2e0f69057a58a5cf2abb2f2b2c8d1a705d297c25.tar
patches-2e0f69057a58a5cf2abb2f2b2c8d1a705d297c25.tar.gz
gnu: bioinformatics: Return #t from all phases and snippets.
* gnu/packages/bioinformatics.scm (bamtools, ribotaper, bioawk) (codingquarry, fraggenescan, minced, pplacer, star, subread, sailfish) (salmon): Return #t from all phases and snippets, use 'invoke' where appropriate, and remove vestigal plumbing.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm47
1 files changed, 31 insertions, 16 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 58cee5cbbe..28b6cd318b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -281,7 +281,8 @@ instance, it implements several methods to assess contig-wise read coverage.")
(setenv "LDFLAGS"
(string-append
"-Wl,-rpath="
- (assoc-ref outputs "out") "/lib/bamtools")))))))
+ (assoc-ref outputs "out") "/lib/bamtools"))
+ #t)))))
(inputs `(("zlib" ,zlib)))
(home-page "https://github.com/pezmaster31/bamtools")
(synopsis "C++ API and command-line toolkit for working with BAM data")
@@ -496,7 +497,8 @@ BED, GFF/GTF, VCF.")
'("create_annotations_files.bash"
"create_metaplots.bash"
"Ribotaper_ORF_find.sh"
- "Ribotaper.sh"))))))))
+ "Ribotaper.sh")))
+ #t)))))
(inputs
`(("bedtools" ,bedtools-2.18)
("samtools" ,samtools-0.1)
@@ -591,7 +593,8 @@ independently with transcriptional regulation.")
(man (string-append out "/share/man/man1")))
(mkdir-p man)
(copy-file "awk.1" (string-append man "/bioawk.1"))
- (install-file "bioawk" bin)))))))
+ (install-file "bioawk" bin))
+ #t)))))
(home-page "https://github.com/lh3/bioawk")
(synopsis "AWK with bioinformatics extensions")
(description "Bioawk is an extension to Brian Kernighan's awk, adding the
@@ -1811,7 +1814,8 @@ databases.")
(copy-recursively "QuarryFiles"
(string-append out "/QuarryFiles"))
(install-file "CodingQuarry" bin)
- (install-file "CufflinksGTF_to_CodingQuarryGFF3.py" bin)))))))
+ (install-file "CufflinksGTF_to_CodingQuarryGFF3.py" bin))
+ #t)))))
(inputs `(("openmpi" ,openmpi)))
(native-search-paths
(list (search-path-specification
@@ -2727,7 +2731,8 @@ Illumina, Roche 454, and the SOLiD platform.")
(share (string-append out "/share/fraggenescan/train")))
(install-file "run_FragGeneScan.pl" bin)
(install-file "FragGeneScan" bin)
- (copy-recursively "train" share))))
+ (copy-recursively "train" share))
+ #t))
(delete 'check)
(add-after 'install 'post-install-check
;; In lieu of 'make check', run one of the examples and check the
@@ -4153,7 +4158,8 @@ probabilistic distances of genome abundance and tetranucleotide frequency.")
"#!" (assoc-ref inputs "bash") "/bin/sh\n\n"
(assoc-ref inputs "jre") "/bin/java -jar "
bin "/minced.jar \"$@\"\n"))))
- (chmod wrapper #o555)))))))
+ (chmod wrapper #o555))
+ #t)))))
(native-inputs
`(("jdk" ,icedtea "jdk")))
(inputs
@@ -4408,7 +4414,7 @@ downstream analysis.")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'enter-scripts-dir
- (lambda _ (chdir "scripts")))
+ (lambda _ (chdir "scripts") #t))
(replace 'check
(lambda _ (invoke "python" "-m" "unittest" "discover" "-v") #t))
(add-after 'install 'wrap-executables
@@ -6019,7 +6025,8 @@ application of SortMeRNA is filtering rRNA from metatranscriptomic data.")
(lambda _
(substitute* "Makefile"
(("(COMPILATION_TIME_PLACE=\")(.*)(\")" _ pre mid post)
- (string-append pre "Built with Guix" post)))))
+ (string-append pre "Built with Guix" post)))
+ #t))
(add-after 'enter-source-dir 'do-not-use-bundled-htslib
(lambda _
(substitute* "Makefile"
@@ -6103,7 +6110,8 @@ sequences.")
(lambda* (#:key outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
(mkdir-p bin)
- (copy-recursively "../bin" bin))))
+ (copy-recursively "../bin" bin))
+ #t))
;; no "configure" script
(delete 'configure))))
(inputs `(("zlib" ,zlib)))
@@ -12006,11 +12014,13 @@ bytes of memory space, where n is the length of the string.")
(add-after 'unpack 'do-not-look-for-boost
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "CMakeLists.txt"
- (("find_package\\(Boost 1\\.53\\.0") "#"))))
+ (("find_package\\(Boost 1\\.53\\.0") "#"))
+ #t))
(add-after 'unpack 'do-not-assign-to-macro
(lambda _
(substitute* "include/spdlog/details/format.cc"
- (("const unsigned CHAR_WIDTH = 1;") ""))))
+ (("const unsigned CHAR_WIDTH = 1;") ""))
+ #t))
(add-after 'unpack 'prepare-rapmap
(lambda* (#:key inputs #:allow-other-keys)
(let ((src "external/install/src/rapmap/")
@@ -12026,7 +12036,8 @@ bytes of memory space, where n is the length of the string.")
(for-each (lambda (file)
(install-file file src))
(find-files "/tmp/rapmap/src" "\\.(c|cpp)"))
- (copy-recursively "/tmp/rapmap/include" include))))
+ (copy-recursively "/tmp/rapmap/include" include))
+ #t))
(add-after 'unpack 'use-system-libraries
(lambda* (#:key inputs #:allow-other-keys)
(substitute* '("src/SailfishIndexer.cpp"
@@ -12066,7 +12077,8 @@ bytes of memory space, where n is the length of the string.")
(string-append (getenv "CPLUS_INCLUDE_PATH")
":"
(assoc-ref inputs "eigen")
- "/include/eigen3")))))))
+ "/include/eigen3"))
+ #t)))))
(inputs
`(("boost" ,boost)
("eigen" ,eigen)
@@ -12252,11 +12264,13 @@ performance as its primary goal.")
(add-after 'unpack 'do-not-look-for-boost
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "CMakeLists.txt"
- (("find_package\\(Boost 1\\.53\\.0") "#"))))
+ (("find_package\\(Boost 1\\.53\\.0") "#"))
+ #t))
(add-after 'unpack 'do-not-phone-home
(lambda _
(substitute* "src/Salmon.cpp"
- (("getVersionMessage\\(\\)") "\"\""))))
+ (("getVersionMessage\\(\\)") "\"\""))
+ #t))
(add-after 'unpack 'prepare-rapmap
(lambda* (#:key inputs #:allow-other-keys)
(let ((src "external/install/src/rapmap/")
@@ -12273,7 +12287,8 @@ performance as its primary goal.")
"external/install/include/rapmap/concurrentqueue.h"
"external/install/include/rapmap/FastxParserThreadUtils.hpp"
"external/install/src/rapmap/FastxParser.cpp"
- "external/install/src/rapmap/xxhash.c")))))
+ "external/install/src/rapmap/xxhash.c")))
+ #t))
(add-after 'unpack 'use-system-libraries
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/CMakeLists.txt"