summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-11-14 23:49:19 +0100
committerLudovic Courtès <ludo@gnu.org>2018-11-14 23:49:19 +0100
commit21f7d88e7a5c6862f8c001a4877620dfeeb11904 (patch)
tree938c03ff6548f7e6d1f704a2e0429a1d987ae94b /gnu
parent79ee97a144aaaa890be0724aaf796e2a771179d7 (diff)
downloadpatches-21f7d88e7a5c6862f8c001a4877620dfeeb11904.tar
patches-21f7d88e7a5c6862f8c001a4877620dfeeb11904.tar.gz
gnu: texlive-bin: Fix substitution regexp.
This is a followup to commit be200ef316478585059041a33d8f4287017dea5a. * gnu/packages/tex.scm (texlive-bin)[arguments]: In 'disable-failing-test' phase, escape "|" characters.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cbe601ea9d..916aa54d58 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -199,7 +199,7 @@
;; FIXME: This test fails on 32-bit architectures since Glibc 2.28:
;; <https://bugzilla.redhat.com/show_bug.cgi?id=1631847>.
(substitute* "texk/web2c/omegafonts/check.test"
- (("^\\./omfonts -ofm2opl \\$srcdir/tests/check tests/xcheck || exit 1")
+ (("^\\./omfonts -ofm2opl \\$srcdir/tests/check tests/xcheck \\|\\| exit 1")
"./omfonts -ofm2opl $srcdir/tests/check tests/xcheck || exit 77"))
#t))
(add-after 'install 'postint