summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-01 18:50:57 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-03 21:38:47 +0200
commitf809c963c21596a0b14d9554ea34ab7ddb293b5e (patch)
tree38d4a4a96b7478ccdc959678fac19059b2083d3e /gnu
parentc2b14516e8f813a87c4aa9a29970226d5ec969b0 (diff)
downloadpatches-f809c963c21596a0b14d9554ea34ab7ddb293b5e.tar
patches-f809c963c21596a0b14d9554ea34ab7ddb293b5e.tar.gz
gnu: Add java-osgi-namespace-extender.
* gnu/packages/java.scm (java-osgi-namespace-extender): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 515188b04f..ae51769331 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -4914,3 +4914,31 @@ the definition of common types in osgi packages.")
and service platform for the Java programming language. This package contains
the names for the attributes and directives for a namespace with contracts.")
(license license:asl2.0)))
+
+(define-public java-osgi-namespace-extender
+ (package
+ (name "java-osgi-namespace-extender")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://central.maven.org/maven2/org/osgi/"
+ "org.osgi.namespace.extender/"
+ version "/org.osgi.namespace.extender-"
+ version "-sources.jar"))
+ (sha256
+ (base32
+ "0jgqiak2i05qv6j3gd33xlaifzzc0ylxxk376v2x0apfg3vvixmz"))))
+ (build-system ant-build-system)
+ (inputs
+ `(("resource" ,java-osgi-resource)
+ ("annotation" ,java-osgi-annotation)))
+ (arguments
+ `(#:jar-name "osgi-namespace-extendent.jar"
+ #:tests? #f)); no tests
+ (home-page "http://www.osgi.org")
+ (synopsis "Extender Capability and Requirement Namespace")
+ (description
+ "OSGi, for Open Services Gateway initiative framework, is a module system
+and service platform for the Java programming language. This package contains
+the names for the attributes and directives for a namespace with extensions.")
+ (license license:asl2.0)))