summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-01 18:53:40 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-03 21:38:49 +0200
commitb784962d966c5e6b63f1d55e4f11d68c431d1e49 (patch)
tree1cb9000bf6686c9ed3713a11393973b7ae180c4f /gnu
parentf809c963c21596a0b14d9554ea34ab7ddb293b5e (diff)
downloadpatches-b784962d966c5e6b63f1d55e4f11d68c431d1e49.tar
patches-b784962d966c5e6b63f1d55e4f11d68c431d1e49.tar.gz
gnu: Add java-osgi-namespace-service.
* gnu/packages/java.scm (java-osgi-namespace-service): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index ae51769331..8cc79b1234 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -4940,5 +4940,33 @@ the names for the attributes and directives for a namespace with contracts.")
(description
"OSGi, for Open Services Gateway initiative framework, is a module system
and service platform for the Java programming language. This package contains
-the names for the attributes and directives for a namespace with extensions.")
+the names for the attributes and directives for an extender namespace.")
+ (license license:asl2.0)))
+
+(define-public java-osgi-namespace-service
+ (package
+ (name "java-osgi-namespace-service")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://central.maven.org/maven2/org/osgi/"
+ "org.osgi.namespace.service/"
+ version "/org.osgi.namespace.service-"
+ version "-sources.jar"))
+ (sha256
+ (base32
+ "0qmw8n2449nkmm56d1znz9zhazb6ya3vsimd5bf5jg23zzhgl8c8"))))
+ (build-system ant-build-system)
+ (inputs
+ `(("resource" ,java-osgi-resource)
+ ("annotation" ,java-osgi-annotation)))
+ (arguments
+ `(#:jar-name "osgi-namespace-service.jar"
+ #:tests? #f)); no tests
+ (home-page "http://www.osgi.org")
+ (synopsis "Service Capability and Requirement Namespace")
+ (description
+ "OSGi, for Open Services Gateway initiative framework, is a module system
+and service platform for the Java programming language. This package contains
+the names for the attributes and directives for a service namespace.")
(license license:asl2.0)))