summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-05-06 14:33:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-05-06 15:47:20 +0200
commit8e020519b45bbdb9403164bd4403f2465bac99ad (patch)
tree91cfce80320b5fd899540d0eddaef5a8dee3b46c /gnu
parent909ebbfc321f854cbc21b5a9e1591c9547508e8e (diff)
downloadpatches-8e020519b45bbdb9403164bd4403f2465bac99ad.tar
patches-8e020519b45bbdb9403164bd4403f2465bac99ad.tar.gz
gnu: gmime: Update to 3.2.0.
* gnu/packages/mail.scm (gmime): Update to 3.2.0. [arguments]: End phases on #t. (gmime-2.6): New public variable. (mu, balsa, pan): Change GMIME to GMIME-2.6.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm29
1 files changed, 22 insertions, 7 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index c492f3163d..6aef8ab85f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2016, 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
-;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -395,7 +395,7 @@ It adds a large amount of new and improved features to mutt.")
(define-public gmime
(package
(name "gmime")
- (version "2.6.23")
+ (version "3.2.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gmime/"
@@ -403,7 +403,7 @@ It adds a large amount of new and improved features to mutt.")
"/gmime-" version ".tar.xz"))
(sha256
(base32
- "0slzlzcr3h8jikpz5a5amqd0csqh2m40gdk910ws2hnaf5m6hjbi"))))
+ "1q6palbpf6lh6bvy9ly26q5apl5k0z0r4mvl6zzqh90rz4rn1v3m"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -427,7 +427,8 @@ It adds a large amount of new and improved features to mutt.")
(let* ((base (basename prog-path))
(prog (which base)))
(string-append pre
- (or prog (error "not found: " base))))))))))))
+ (or prog (error "not found: " base)))))))
+ #t)))))
(home-page "http://spruce.sourceforge.net/gmime/")
(synopsis "MIME message parser and creator library")
(description
@@ -436,6 +437,20 @@ the creation and parsing of messages using the Multipurpose Internet Mail
Extension (MIME).")
(license (list lgpl2.1+ gpl2+ gpl3+))))
+;; Some packages are not ready for GMime 3 yet.
+(define-public gmime-2.6
+ (package
+ (inherit gmime)
+ (version "2.6.23")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gmime/"
+ (version-major+minor version)
+ "/gmime-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0slzlzcr3h8jikpz5a5amqd0csqh2m40gdk910ws2hnaf5m6hjbi"))))))
+
(define-public bogofilter
(package
(name "bogofilter")
@@ -595,7 +610,7 @@ security functionality including PGP, S/MIME, SSH, and SSL.")
`(("xapian" ,xapian)
("guile" ,guile-2.2)
("glib" ,glib)
- ("gmime" ,gmime)))
+ ("gmime" ,gmime-2.6)))
(arguments
`(#:modules ((guix build gnu-build-system)
(guix build utils)
@@ -2426,7 +2441,7 @@ tools and applications:
`(("cyrus-sasl" ,cyrus-sasl)
("enchant" ,enchant)
("gdk-pixbuf" ,gdk-pixbuf)
- ("gmime" ,gmime)
+ ("gmime" ,gmime-2.6)
("gnutls" ,gnutls)
("gpgme" ,gpgme)
("gtk+" ,gtk+)
@@ -2503,7 +2518,7 @@ killed threads.")
"/bin/gpg\"")))
#t)))))
(inputs
- `(("gmime" ,gmime)
+ `(("gmime" ,gmime-2.6)
("gnupg" ,gnupg)
("gnutls" ,gnutls)
("gtk+" ,gtk+)