summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-04 11:22:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-04 11:23:53 +0200
commit8d6c845d68211005a873811f0aa2dbc369bddbb5 (patch)
treeeff35ca9c2558f41a774bdfc635ba143c9124489 /gnu
parenta3cd23b6393e34a6b106ad273d1705adb7685bed (diff)
downloadpatches-8d6c845d68211005a873811f0aa2dbc369bddbb5.tar
patches-8d6c845d68211005a873811f0aa2dbc369bddbb5.tar.gz
gnu: Add r-crosstalk.
* gnu/packages/web.scm (r-crosstalk): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 86a7dc1868..5459a3051d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4852,3 +4852,30 @@ with R. Automatic \"reactive\" binding between inputs and outputs and
extensive prebuilt widgets make it possible to build beautiful,
responsive, and powerful applications with minimal effort.")
(license l:artistic2.0)))
+
+(define-public r-crosstalk
+ (package
+ (name "r-crosstalk")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "crosstalk" version))
+ (sha256
+ (base32
+ "0lfa89vhrzi7a1rghmygcjr8gzddw35sinb3jx6g49mc9jias7mk"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-htmltools" ,r-htmltools)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-lazyeval" ,r-lazyeval)
+ ("r-r6" ,r-r6)
+ ("r-shiny" ,r-shiny)))
+ (home-page "https://rstudio.github.io/crosstalk/")
+ (synopsis "Inter-widget interactivity for HTML widgets")
+ (description
+ "This package provides building blocks for allowing HTML widgets to
+communicate with each other, with Shiny or without (i.e. static @code{.html}
+files). It currently supports linked brushing and filtering.")
+ (license l:expat)))