summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-11 17:01:00 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-14 12:36:49 +0100
commit846e3409540241a05ed10f36e1a4a9b049ad5810 (patch)
treec01038e628d7f4c568c7662c0a62a78ae6254764 /gnu
parent388e05ee1689787adc1dd2eeb57f2360fe4663f2 (diff)
downloadpatches-846e3409540241a05ed10f36e1a4a9b049ad5810.tar
patches-846e3409540241a05ed10f36e1a4a9b049ad5810.tar.gz
gnu: Add pyicoteo.
* gnu/packages/bioinformatics.scm (pyicoteo): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b3d882761b..4925290910 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2556,6 +2556,44 @@ the phenotype as it models the data.")
generated using the PacBio Iso-Seq protocol.")
(license license:bsd-3))))
+(define-public pyicoteo
+ (package
+ (name "pyicoteo")
+ (version "2.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/regulatorygenomicsupf/"
+ "pyicoteo/get/v" version ".tar.bz2"))
+ (file-name (string-append name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0d6087f29xp8wxwlj111c3sylli98n0l8ry58c51ixzq0zfm50wa"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2 ; does not work with Python 3
+ #:tests? #f)) ; there are no tests
+ (inputs
+ `(("python2-matplotlib" ,python2-matplotlib)))
+ (home-page "https://bitbucket.org/regulatorygenomicsupf/pyicoteo")
+ (synopsis "Analyze high-throughput genetic sequencing data")
+ (description
+ "Pyicoteo is a suite of tools for the analysis of high-throughput genetic
+sequencing data. It works with genomic coordinates. There are currently six
+different command-line tools:
+
+@enumerate
+@item pyicoregion: for generating exploratory regions automatically;
+@item pyicoenrich: for differential enrichment between two conditions;
+@item pyicoclip: for calling CLIP-Seq peaks without a control;
+@item pyicos: for genomic coordinates manipulation;
+@item pyicoller: for peak calling on punctuated ChIP-Seq;
+@item pyicount: to count how many reads from N experiment files overlap in a
+ region file;
+@item pyicotrocol: to combine operations from pyicoteo.
+@end enumerate\n")
+ (license license:gpl3+)))
+
(define-public prodigal
(package
(name "prodigal")