summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-02-26 23:36:01 +0530
committerPierre Neidhardt <mail@ambrevar.xyz>2020-02-27 10:45:47 +0100
commit83ee1e91b05e324edcdfbafe5b203064f1caf802 (patch)
tree0c9db7064b3b8489441e94f8091910638fdc7ee0 /gnu
parentb4e0f0dc37d6a3a887e85008194daf4178f827ef (diff)
downloadpatches-83ee1e91b05e324edcdfbafe5b203064f1caf802.tar
patches-83ee1e91b05e324edcdfbafe5b203064f1caf802.tar.gz
gnu: Add emacs-password-generator.
* gnu/packages/emacs-xyz.scm (emacs-password-generator): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 177b2f3406..0120392eaf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21639,3 +21639,25 @@ emoji.")
ExifTool supports reading and writing metadata in various formats including
EXIF, XMP and IPTC.")
(license license:gpl3+)))
+
+(define-public emacs-password-generator
+ (package
+ (name "emacs-password-generator")
+ (version "1.01")
+ (home-page "https://github.com/zargener/emacs-password-genarator")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit "904cdb591a04305ba882ce19e1d117f5fa60f7d3")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qgvn79qz1h8ykm5i1qv2fja4v2y0g2i0n5sf7byhnqhqlwn63nv"))))
+ (build-system emacs-build-system)
+ (synopsis "Generate passwords inside Emacs")
+ (description "@code{emacs-password-generator} provides simple functions to
+generate random passwords and insert them into the current buffer. It also
+supports generation of phonetic and numeric passwords.")
+ (license license:artistic2.0)))