summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2017-09-06 10:07:55 +0300
committerLudovic Courtès <ludo@gnu.org>2017-09-08 18:08:58 +0200
commit4967946b8ae81794971f72fe2e40a2bc428f91b6 (patch)
tree351b72b0e053f2875d7b6d8c6665bbc93bf0f580 /gnu
parenta5d6b0a3d2905dd260cbc540592a434f9827786d (diff)
downloadpatches-4967946b8ae81794971f72fe2e40a2bc428f91b6.tar
patches-4967946b8ae81794971f72fe2e40a2bc428f91b6.tar.gz
gnu: Add python-uritemplate.
* gnu/packages/python.scm (python-uritemplate, python2-uritemplate): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c6f9f34ce7..bf669a5317 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -16227,3 +16227,24 @@ ECB and OFB).")
(define-public python2-pyaes
(package-with-python2 python-pyaes))
+
+(define-public python-uritemplate
+ (package
+ (name "python-uritemplate")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "uritemplate" version))
+ (sha256
+ (base32
+ "0781gm9g34wa0asc19dx81ng0nqq07igzv3bbvdqmz13pv7469n0"))))
+ (build-system python-build-system)
+ (home-page "https://uritemplate.readthedocs.org")
+ (synopsis "Library to deal with URI Templates")
+ (description "@code{uritemplate} provides Python library to deal with URI
+Templates.")
+ (license license:bsd-2)))
+
+(define-public python2-uritemplate
+ (package-with-python2 python-uritemplate))