summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-23 23:09:51 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-25 20:49:59 +0800
commitf5deff7a033e2b3fd0e8aceb094798e59f692d4c (patch)
tree8908f0d3342aab76ea5f57391f7b458f8f2f001c /gnu
parent1899556655dda2dbffcf5e76f8f2796d64e37a20 (diff)
downloadpatches-f5deff7a033e2b3fd0e8aceb094798e59f692d4c.tar
patches-f5deff7a033e2b3fd0e8aceb094798e59f692d4c.tar.gz
gnu: Add python-cleo and python2-cleo.
* gnu/packages/python.scm (python-cleo, python2-cleo): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1dc521220e..d1d127bab9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9391,3 +9391,31 @@ Wikipedia code samples at
(define-public python2-pylev
(package-with-python2 python-pylev))
+(define-public python-cleo
+ (package
+ (name "python-cleo")
+ (version "0.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "cleo" version))
+ (sha256
+ (base32
+ "1k2dcl6mqpn5bljyl6w42rqyd9mb3y9kh2mg7m2x3kfjwvg0rpva"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-psutil" ,python-psutil)
+ ("python-pylev" ,python-pylev)
+ ("python-setuptools" ,python-setuptools)
+ ;; For testing
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/sdispater/cleo")
+ (synopsis "Command-line arguments library for Python")
+ (description
+ "Cleo allows you to create command-line commands with signature in
+docstring and colored output.")
+ (license license:expat)))
+
+(define-public python2-cleo
+ (package-with-python2 python-cleo))
+