summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-08 15:05:11 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-08 16:02:32 +0800
commitdfbce50cdf36db8fe094afc50c3a24ae3a403839 (patch)
treed94d543e1dd8aa6ddbc32d60d7a3b46f2762d8af /gnu
parent674fca0e41f3d227d436aa26f6c970d44536bc0e (diff)
downloadpatches-dfbce50cdf36db8fe094afc50c3a24ae3a403839.tar
patches-dfbce50cdf36db8fe094afc50c3a24ae3a403839.tar.gz
gnu: gtk+-2: Add more inputs.
* gnu/packages/gtk.scm (gtk+-2)[inputs]: Add cups, libxcomposite, libxcursor, libxdamage, libxi, libxinerama and libxrandr. [native-inputs]: Add gettext. [arguments]: Add #:configure-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 2ecaeb65e3..53d4122f7c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
+;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -405,14 +406,25 @@ is part of the GNOME accessibility project.")
`(("atk" ,atk)
("gdk-pixbuf" ,gdk-pixbuf)
("pango" ,pango)))
+ (inputs
+ `(("cups" ,cups)
+ ("libxcomposite" ,libxcomposite)
+ ("libxcursor" ,libxcursor)
+ ("libxdamage" ,libxdamage)
+ ("libxi" ,libxi)
+ ("libxinerama" ,libxinerama)
+ ("libxrandr" ,libxrandr)))
(native-inputs
`(("perl" ,perl)
+ ("gettext" ,gnu-gettext)
("glib" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
(arguments
`(#:make-flags '("CC=gcc")
+ #:configure-flags
+ (list "--with-xinput=yes")
#:phases
(alist-cons-before
'configure 'disable-tests