summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-03-27 15:54:30 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-04-08 17:31:12 +0200
commitdeb36de072167533597dfdca3ad21dc2e7291430 (patch)
tree4e6ba27ae50ba55be30deffea486ff219b1e63ed /gnu
parente916e211023e34c2a01c36dd8378fbe4acadff3d (diff)
downloadpatches-deb36de072167533597dfdca3ad21dc2e7291430.tar
patches-deb36de072167533597dfdca3ad21dc2e7291430.tar.gz
gnu: Add ghc-text.
* gnu/packages/haskell.scm (ghc-text): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2e8244aca3..e8013f6f36 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -350,4 +350,35 @@ access to the full zlib feature set.")
"This package provides a library for parallel programming.")
(license bsd-3)))
+(define-public ghc-text
+ (package
+ (name "ghc-text")
+ (version "1.2.0.4")
+ (outputs '("out" "doc"))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/text/text-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "004p1c74crs8wmjafwsmw3mmycspq1j8fpm1lvfpq6acha7bnpc6"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
+ (home-page "https://github.com/bos/text")
+ (synopsis
+ "Efficient packed Unicode text type library.")
+ (description
+ "An efficient packed, immutable Unicode text type (both strict and
+lazy), with a powerful loop fusion optimization framework.
+
+The 'Text' type represents Unicode character strings, in a time and
+space-efficient manner. This package provides text processing
+capabilities that are optimized for performance critical use, both
+in terms of large data quantities and high speed.")
+ (license bsd-3)))
+
;;; haskell.scm ends here