summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-22 20:24:33 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-22 20:24:33 +0200
commitb92eee75b15d872bd70ab4abaa04c2fe4b7d45c1 (patch)
treeeca547c8130c25df1462f874a5a146cc38a90152 /gnu
parentd038cac12ac8d48a79b79653e8dd876a3fffae3c (diff)
downloadpatches-b92eee75b15d872bd70ab4abaa04c2fe4b7d45c1.tar
patches-b92eee75b15d872bd70ab4abaa04c2fe4b7d45c1.tar.gz
gnu: Add GLPK.
* gnu/packages/maths.scm (glpk): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a76220a052..ccbb57b90f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -26,6 +26,7 @@
#:use-module (gnu packages compression)
#:use-module ((gnu packages gettext)
#:renamer (symbol-prefix-proc 'gnu:))
+ #:use-module (gnu packages multiprecision)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages readline)
@@ -89,6 +90,33 @@ differential equations, linear algebra, Fast Fourier Transforms and random
numbers.")
(license license:gpl3+)))
+(define-public glpk
+ (package
+ (name "glpk")
+ (version "4.52.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/glpk/glpk-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0nz9ngmx23c8gbjr8l8ygnfaanxj2mwbl8awpg630bgrkxdnhc9j"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gmp" ,gmp)))
+ (arguments
+ `(#:configure-flags '("--with-gmp")))
+ (home-page "http://www.gnu.org/software/glpk/")
+ (synopsis "NU Linear Programming Kit, supporting the MathProg language")
+ (description
+ "GLPK is a C library for solving large-scale linear programming (LP),
+mixed integer programming (MIP), and other related problems. It supports the
+GNU MathProg modeling language, a subset of the AMPL language, and features a
+translator for the language. In addition to the C library, a stand-alone
+LP/MIP solver is included in the package.")
+ (license license:gpl3+)))
+
(define-public pspp
(package
(name "pspp")