summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-10 22:10:13 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-10 22:26:44 +0800
commitb3455870e1225d14ebeae6738e10bd3e1bbcf626 (patch)
tree840bd7fc8fb7d6a71c18a8330d5b7ddb7377f4d3 /gnu
parent3a4de6b2d2fdb515c8186cbceab4259aab91cadf (diff)
downloadpatches-b3455870e1225d14ebeae6738e10bd3e1bbcf626.tar
patches-b3455870e1225d14ebeae6738e10bd3e1bbcf626.tar.gz
gnu: libvpx: Augment rpath.
Fixes <http://bugs.gnu.org/20055>. * gnu/packages/video.scm (libvpx)[arguments]: Set LDFLAGS to '-Wl,-rpath=$out/lib' in configure phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 16c9770f45..5dd4531ec4 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -819,6 +819,8 @@ projects while introducing many more.")
(lambda* (#:key outputs #:allow-other-keys)
(setenv "CONFIG_SHELL" (which "bash"))
(let ((out (assoc-ref outputs "out")))
+ (setenv "LDFLAGS"
+ (string-append "-Wl,-rpath=" out "/lib"))
(zero? (system* "./configure"
"--enable-shared"
"--as=yasm"