summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-23 23:07:39 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-25 20:49:59 +0800
commitae43baa890cf7957b87f8218263cc8ac95343c58 (patch)
treeee2d42bad8a47e6bb677658e02306baf939fc2a4 /gnu
parent9250b0f3bf05da7e3f8b1cfaf9ce0c603ed72abf (diff)
downloadpatches-ae43baa890cf7957b87f8218263cc8ac95343c58.tar
patches-ae43baa890cf7957b87f8218263cc8ac95343c58.tar.gz
gnu: Add python-arrow and python2-arrow.
* gnu/packages/python.scm (python-arrow, python2-arrow): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0c9bd22ee6..6e30377005 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9316,3 +9316,31 @@ objects, patterned after the Mocha library for Ruby.")
(define-public python2-chai
(package-with-python2 python-chai))
+(define-public python-arrow
+ (package
+ (name "python-arrow")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "arrow" version))
+ (sha256
+ (base32
+ "1bz7hkdgpqcjs866y58z8jywpy7al0f4rxdr00bh2l5qddyw245j"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-dateutil" ,python-dateutil-2)
+ ;; For testing
+ ("python-chai" ,python-chai)
+ ("python-simplejson" ,python-simplejson)))
+ (home-page "https://github.com/crsmithdev/arrow/")
+ (synopsis "Dates and times for Python")
+ (description
+ "Arrow is a Python library to creating, manipulating, formatting and
+converting dates, times, and timestamps. It implements and updates the
+datetime type.")
+ (license asl2.0)))
+
+(define-public python2-arrow
+ (package-with-python2 python-arrow))
+