summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2017-09-05 11:56:34 -0400
committerLudovic Courtès <ludo@gnu.org>2017-09-08 18:08:31 +0200
commita5d6b0a3d2905dd260cbc540592a434f9827786d (patch)
treecb16c7dc1e09a17ebff20684c569b1bdf5f489d2 /gnu
parenta79830d03542bd376e13201eb24ec28a0197f5a6 (diff)
downloadpatches-a5d6b0a3d2905dd260cbc540592a434f9827786d.tar
patches-a5d6b0a3d2905dd260cbc540592a434f9827786d.tar.gz
gnu: notmuch-addrlookup-c: Update to 8-1.88f156d.
* gnu/packages/mail.scm (notmuch-addrlookup-c): Update to 8-1.88f156d. [source]: Use git-fetch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm82
1 files changed, 44 insertions, 38 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index d8486222f9..9469e96022 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -727,45 +727,51 @@ ing, and tagging large collections of email messages.")
(license gpl3+)))
(define-public notmuch-addrlookup-c
- (package
- (name "notmuch-addrlookup-c")
- (version "7")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/aperezdc/" name "/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0rslg2ifgyhl6asv3yr1f62m9xjfcinv7i6qb07h2k217jqlmrri"))))
- (build-system gnu-build-system)
- (arguments
- '(#:tests? #f ; no tests
- #:make-flags (list "CC=gcc"
- (string-append "PREFIX="
- (assoc-ref %outputs "out")))
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- ;; Remove vim code completion config, it's not needed to
- ;; build (or be patched).
- (add-before 'patch-source-shebangs 'delete-ycm-file
- (lambda _ (delete-file ".ycm_extra_conf.py")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append
- (assoc-ref outputs "out") "/bin")))
- (install-file "notmuch-addrlookup" bin)))))))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("glib" ,glib)
- ("notmuch" ,notmuch)))
- (home-page "https://github.com/aperezdc/notmuch-addrlookup-c")
- (synopsis "Address lookup tool for Notmuch")
- (description "This is an address lookup tool using a Notmuch database,
+ ;; This commit includes a compatibility fix for notmuch-0.25, and is not
+ ;; currently part of any release. Please update this package when
+ ;; notmuch-addrlookup-c-9 is released.
+ (let ((commit "88f156d04990a71c6ad6fc2757b537b44e3c4d00")
+ (revision "1")) ;Guix package revision
+ (package
+ (name "notmuch-addrlookup-c")
+ (version (string-append "8-" revision "."
+ (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aperezdc/notmuch-addrlookup-c.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0v0wzs7qzy4n1hbql8s10qrwgalcxdzbxf8pj6cii1pv2jwmkxbm"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ ;; Remove vim code completion config, it's not needed to
+ ;; build (or be patched).
+ (add-before 'patch-source-shebangs 'delete-ycm-file
+ (lambda _ (delete-file ".ycm_extra_conf.py")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append
+ (assoc-ref outputs "out") "/bin")))
+ (install-file "notmuch-addrlookup" bin)))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("notmuch" ,notmuch)))
+ (home-page "https://github.com/aperezdc/notmuch-addrlookup-c")
+ (synopsis "Address lookup tool for Notmuch")
+ (description "This is an address lookup tool using a Notmuch database,
useful for email address completion.")
- (license license:expat)))
+ (license license:expat))))
(define-public python-notmuch
(package