summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-04 18:25:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-15 17:03:14 +0200
commit99952c538b5931bca814b47d840ce83e41e46f4e (patch)
tree6edcdc09f301c3658f49dfda65072380fb8e2b22 /gnu
parent9d913b251be14f36ec6660b3375758ed191bc2e2 (diff)
downloadpatches-99952c538b5931bca814b47d840ce83e41e46f4e.tar
patches-99952c538b5931bca814b47d840ce83e41e46f4e.tar.gz
gnu: Add texlive-generic-unicode-data.
* gnu/packages/tex.scm (texlive-generic-unicode-date): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b1adec5d99..9e05eee516 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -218,6 +218,44 @@ to PostScript.")
license:expat
license:lgpl3+))))
+(define-public texlive-generic-unicode-data
+ (package
+ (name "texlive-generic-unicode-data")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/generic/unicode-data"))
+ (revision %texlive-revision)))
+ (sha256
+ (base32
+ "0ivrhp6jz31pl4z841g4ws41lmvdiwz4sslmhf02inlib79gz6r2"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/generic/unicode-data")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/unicode-data")
+ (synopsis "Unicode data and loaders for TeX")
+ (description "This bundle provides generic access to Unicode Consortium
+data for TeX use. It contains a set of text files provided by the Unicode
+Consortium which are currently all from Unicode 8.0.0, with the exception of
+@code{MathClass.txt} which is not currently part of the Unicode Character
+Database. Accompanying these source data are generic TeX loader files
+allowing this data to be used as part of TeX runs, in particular in building
+format files. Currently there are two loader files: one for general character
+set up and one for initializing XeTeX character classes as has been carried
+out to date by @code{unicode-letters.tex}. ")
+ (license license:lppl1.3c+)))
+
(define texlive-texmf
(package
(name "texlive-texmf")