summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-24 13:32:24 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-24 13:32:58 +0100
commit8e77da0d11770f7761e6c3fbde0abe05a44491e7 (patch)
tree807711261ddd765056bd13a0f08c38f903680818 /gnu
parent9b0dae2222638ec3fe4bc30dcab3cffd41f918e2 (diff)
downloadpatches-8e77da0d11770f7761e6c3fbde0abe05a44491e7.tar
patches-8e77da0d11770f7761e6c3fbde0abe05a44491e7.tar.gz
gnu: bambam: Update to 1.0.0.
* gnu/packages/games.scm (bambam): Update to 1.0.0. [arguments]: Use default Python (3). Delete obsolete ‘patch-data-dir-location’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3d825cbe61..613b3acfeb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3840,29 +3840,22 @@ programmers may also add their own favorite language.")
(define-public bambam
(package
(name "bambam")
- (version "0.6")
+ (version "1.0.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/porridge/bambam")
- (commit version)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "08hcd0gzia3pz7fzk4pqc5kbq1074j4q0jcmbpgvr7n623nj2xa5"))))
+ (base32 "18cwd1wpyyx8y61cags9bkdhx9x858xicc4y1c9c2s0xjmgzhl3i"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2
- #:tests? #f ; no tests
+ `(#:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
- (delete 'build)
- (add-before 'install 'patch-data-dir-location
- (lambda _
- (substitute* "bambam.py"
- (("'data'") "'../share/bambam/data'"))
- #t))
+ (delete 'build) ; nothing to build
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))