summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-08 16:01:49 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-10-26 11:22:17 -0500
commit8caeb11772cc1df06cb6bf227c3280ae6858bd59 (patch)
tree6d6820d85df1fcc62b6a91de4865abbbcd392be6 /gnu
parentaba646397501e6daf0018c0c11b215ee93b9548e (diff)
downloadpatches-8caeb11772cc1df06cb6bf227c3280ae6858bd59.tar
patches-8caeb11772cc1df06cb6bf227c3280ae6858bd59.tar.gz
gnu: Add autossh.
* gnu/packages/ssh.scm (autossh): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ssh.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index af5aae1029..5fdeeb74a4 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -506,3 +507,28 @@ manipulating key files.")
authentication with SSH's so-called @dfn{interactive keyboard password
authentication}.")
(license license:gpl2+)))
+
+(define-public autossh
+ (package
+ (name "autossh")
+ (version "1.4e")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.harding.motd.ca/autossh/autossh-"
+ version ".tgz"))
+ (sha256
+ (base32 "0mlicw28vq2jxa0jf0dys5ja75v0fxpjavlq9dpif6bnknji13ly"))))
+ (build-system gnu-build-system)
+ (arguments `(#:tests? #f)) ; There is no "make check" or anything similar
+ (inputs `(("openssh" ,openssh)))
+ (synopsis "Automatically restart SSH sessions and tunnels")
+ (description "autossh is a program to start a copy of @command{ssh} and
+monitor it, restarting it as necessary should it die or stop passing traffic.")
+ (home-page "http://www.harding.motd.ca/autossh/")
+ (license
+ ;; Why point to a source file? Well, all the individual files have a
+ ;; copy of this license in their headers, but there's no separate file
+ ;; with that information.
+ (license:non-copyleft "file://autossh.c"))))