summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-05-02 15:32:30 +0200
committerLudovic Courtès <ludo@gnu.org>2019-05-02 15:32:30 +0200
commit746ac457cc2748152a3a39d4296972fa20f19741 (patch)
tree978f3bdb71cfd062df8da9be7ae0218d214626e1 /gnu
parentc457f109bec75bfbf4619f3e18bcd82c33a15c07 (diff)
parent3a3e9f2bb586e79a7931163f0191df61591b8017 (diff)
downloadpatches-746ac457cc2748152a3a39d4296972fa20f19741.tar
patches-746ac457cc2748152a3a39d4296972fa20f19741.tar.gz
Merge branch 'version-1.0.0'
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm8
-rw-r--r--gnu/packages/libusb.scm5
-rw-r--r--gnu/packages/package-management.scm8
-rw-r--r--gnu/services/desktop.scm14
-rw-r--r--gnu/system/examples/vm-image.tmpl8
-rw-r--r--gnu/system/vm.scm10
6 files changed, 45 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d33af15a29..8e3b7a406a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4633,6 +4633,14 @@ classes for commonly used data structures.")
(base32
"1qbcwq89g4r67k1dj4laqj441pj4195c8hzhxn8vc6mmg8adg6kx"))))
(build-system meson-build-system)
+ (arguments
+ ;; On 32-bit platforms, the test fails with a rounding error:
+ ;; <https://bugzilla.gnome.org/show_bug.cgi?id=775249>. Just skip it for
+ ;; now.
+ (if (and (not (%current-target-system))
+ (member (%current-system) '("i686-linux" "armhf-linux")))
+ '(#:tests? #f)
+ '()))
(native-inputs
`(("glib" ,glib "bin")
("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 61329d27a1..5ef62e47fb 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -314,6 +314,11 @@ wrapper for accessing libusb-1.0.")
(base32
"00pnh9zf3iwdji2faccns7vagbmbrwbj9a8zp9s53a6rqaa9czis"))))
(build-system gnu-build-system)
+ (arguments
+ ;; Tests fail randomly when run in parallel because several of them write
+ ;; and read to/from the same file--e.g., "4.plist" is accessed by
+ ;; 'large.test' and 'largecmp.test'.
+ '(#:parallel-tests? #f))
(inputs
`(("python" ,python)))
(native-inputs
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 697a04e098..d80451ce4d 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -109,9 +109,9 @@
;; Latest version of Guix, which may or may not correspond to a release.
;; Note: the 'update-guix-package.scm' script expects this definition to
;; start precisely like this.
- (let ((version "0.16.0")
- (commit "0c329bf4b0c00abdc9a7d9c818d36d4d60b3005d")
- (revision 14))
+ (let ((version "1.0.0")
+ (commit "326dcbf1b3c30aa525185fda435c34cb9495dd04")
+ (revision 1))
(package
(name "guix")
@@ -127,7 +127,7 @@
(commit commit)))
(sha256
(base32
- "1403vrazx46w9hcvqjyxa4ipwvqv0432f6rsn4981w1n3p1j4mf6"))
+ "0k9v9lh69q353x055id1sq1gx4p8idg8ifrgidv5s73wdil2cflm"))
(file-name (string-append "guix-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
diff --git a/gnu/services/desktop.scm b/gnu/services/desktop.scm
index f31dbc112e..5e0bd102a2 100644
--- a/gnu/services/desktop.scm
+++ b/gnu/services/desktop.scm
@@ -84,6 +84,7 @@
udisks-service
udisks-service-type
+ colord-service-type
colord-service
geoclue-application
@@ -93,6 +94,9 @@
geoclue-service
geoclue-service-type
+ bluetooth-service-type
+ bluetooth-configuration
+ bluetooth-configuration?
bluetooth-service
elogind-configuration
@@ -452,7 +456,9 @@ site} for more information."
`(("bluetooth"
,(bluetooth-directory config)))))
(service-extension shepherd-root-service-type
- (compose list bluetooth-shepherd-service))))))
+ (compose list bluetooth-shepherd-service))))
+ (description "Run the @command{bluetoothd} daemon, which manages all the
+Bluetooth devices and provides a number of D-Bus interfaces.")))
(define* (bluetooth-service #:key (bluez bluez) (auto-enable? #f))
"Return a service that runs the @command{bluetoothd} daemon, which manages
@@ -506,7 +512,11 @@ Users need to be in the @code{lp} group to access the D-Bus service.
(service-extension udev-service-type list)
;; It provides polkit "actions".
- (service-extension polkit-service-type list)))))
+ (service-extension polkit-service-type list)))
+ (description
+ "Run @command{colord}, a system service with a D-Bus
+interface to manage the color profiles of input and output devices such as
+screens and scanners.")))
(define* (colord-service #:key (colord colord))
"Return a service that runs @command{colord}, a system service with a D-Bus
diff --git a/gnu/system/examples/vm-image.tmpl b/gnu/system/examples/vm-image.tmpl
index a140082c0b..0dbd31fe0a 100644
--- a/gnu/system/examples/vm-image.tmpl
+++ b/gnu/system/examples/vm-image.tmpl
@@ -4,9 +4,10 @@
;; guix system reconfigure /etc/config.scm
;;
-(use-modules (gnu) (srfi srfi-1))
+(use-modules (gnu) (guix) (srfi srfi-1))
(use-service-modules desktop networking ssh xorg)
-(use-package-modules bootloaders certs fonts nvi wget xorg)
+(use-package-modules bootloaders certs fonts nvi
+ package-management wget xorg)
(define vm-image-motd (plain-file "motd" "
\x1b[1;37mThis is the GNU system. Welcome!\x1b[0m
@@ -34,6 +35,9 @@ accounts.\x1b[0m
(locale "en_US.utf8")
(keyboard-layout (keyboard-layout "us" "altgr-intl"))
+ ;; Label for the GRUB boot menu.
+ (label (string-append "GNU Guix " (package-version guix)))
+
(firmware '())
;; Below we assume /dev/vda is the VM's hard disk.
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index 92b03b01ad..124abd0fc9 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -283,6 +283,11 @@ INPUTS is a list of inputs (as for packages)."
(sql-schema #$schema)
+ ;; Allow non-ASCII file names--e.g., 'nss-certs'--to be decoded.
+ (setenv "GUIX_LOCPATH"
+ #+(file-append glibc-utf8-locales "/lib/locale"))
+ (setlocale LC_ALL "en_US.utf8")
+
(let ((inputs
'#$(append (list qemu parted e2fsprogs dosfstools xorriso)
(map canonical-package
@@ -379,6 +384,11 @@ the image."
(sql-schema #$schema)
+ ;; Allow non-ASCII file names--e.g., 'nss-certs'--to be decoded.
+ (setenv "GUIX_LOCPATH"
+ #+(file-append glibc-utf8-locales "/lib/locale"))
+ (setlocale LC_ALL "en_US.utf8")
+
(let ((inputs
'#$(append (list qemu parted e2fsprogs dosfstools)
(map canonical-package