summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMike Gerwitz <mtg@gnu.org>2017-11-29 22:42:36 -0500
committerLudovic Courtès <ludo@gnu.org>2017-12-01 11:28:48 +0100
commit491cbd3553f36983555bd0aa22124dc580f6484b (patch)
tree3912297aea1f074cf1ebda724bbab1146e03c47c /gnu
parentc03ba83c17c91e34e811a909fae0f63aab701ff9 (diff)
downloadpatches-491cbd3553f36983555bd0aa22124dc580f6484b.tar
patches-491cbd3553f36983555bd0aa22124dc580f6484b.tar.gz
gnu: Add emacs-evil-matchit.
* gnu/packages/emacs.scm (emacs-evil-matchit): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 78728a5b9c..e5e6cf0979 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6358,3 +6359,25 @@ Feautures:
@item Quickly change frame and font sizes.
@end itemize\n")
(license license:expat)))
+
+(define-public emacs-evil-matchit
+ (package
+ (name "emacs-evil-matchit")
+ (version "2.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/redguardtoo/evil-matchit/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hm0k53m7d8zv2pk4p93k5mmilsv1mz7y2z6dqf7r6f0zmncs31a"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/redguardtoo/evil-matchit")
+ (synopsis "Vim matchit ported into Emacs")
+ (description
+ "@code{evil-matchit} is a minor mode for jumping between matching tags in
+evil mode using @kbd{%}. It is a port of @code{matchit} for Vim.")
+ (license license:gpl3+)))