summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-11-27 16:21:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-30 17:38:36 +0100
commit117d8cc40e9983098a080fe41cce7684b312351c (patch)
treeea716cba453370b5dd6de893930c7e7c63999d43 /gnu
parentf1b90a2b58aca0875ebfff78434478ea4b580c30 (diff)
downloadpatches-117d8cc40e9983098a080fe41cce7684b312351c.tar
patches-117d8cc40e9983098a080fe41cce7684b312351c.tar.gz
gnu: jellyfish: Update to 2.2.7.
* gnu/packages/bioinformatics.scm (jellyfish): Update to 2.2.7. [native-inputs]: Add pkg-config. [inputs]: Add htslib.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 03054c91d1..5b3eec86db 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3292,7 +3292,7 @@ experiments and provide highly stable thresholds based on reproducibility.")
(define-public jellyfish
(package
(name "jellyfish")
- (version "2.2.4")
+ (version "2.2.7")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/gmarcais/Jellyfish/"
@@ -3300,7 +3300,7 @@ experiments and provide highly stable thresholds based on reproducibility.")
"/jellyfish-" version ".tar.gz"))
(sha256
(base32
- "0a6xnynqy2ibfbfz86b9g2m2dgm7f1469pmymkpam333gi3p26nk"))))
+ "1a1iwq9pq54k2m9ypvwl5s0bqfl64gwh9dx5af9i382ajas2016q"))))
(build-system gnu-build-system)
(outputs '("out" ;for library
"ruby" ;for Ruby bindings
@@ -3323,7 +3323,10 @@ experiments and provide highly stable thresholds based on reproducibility.")
`(("bc" ,bc)
("time" ,time)
("ruby" ,ruby)
- ("python" ,python-2)))
+ ("python" ,python-2)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("htslib" ,htslib)))
(synopsis "Tool for fast counting of k-mers in DNA")
(description
"Jellyfish is a tool for fast, memory-efficient counting of k-mers in