summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRene Saavedra <rennes@openmailbox.org>2016-10-15 21:51:25 -0500
committerKei Kebreau <kei@openmailbox.org>2016-10-17 15:09:31 -0400
commit0bd697591bd5f020032cc2650fa6f0f43377ff67 (patch)
tree554717fa4d93fd6532bef0a8a03c7f8cddcad134 /gnu
parent509372970408584d769d0152bdaececccba753e4 (diff)
downloadpatches-0bd697591bd5f020032cc2650fa6f0f43377ff67.tar
patches-0bd697591bd5f020032cc2650fa6f0f43377ff67.tar.gz
gnu: Add xpad.
* gnu/packages/gnome.scm (xpad): New variable. Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2b75781d21..52d6cd4c82 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5544,3 +5544,31 @@ handling the startup notification side.")
"Calculator is an application that solves mathematical equations and
is suitable as a default application in a Desktop environment.")
(license license:gpl3)))
+
+(define-public xpad
+ (package
+ (name "xpad")
+ (version "4.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/xpad/trunk/4.8.0/+download/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "17f915yyvfa2fsavq6wh0q0dfhib28b4k1gc0292b9xdlrvy7f22"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("gtksourceview" ,gtksourceview)
+ ("libsm" ,libsm)))
+ (home-page "https://wiki.gnome.org/Apps/Xpad")
+ (synopsis "Virtual sticky note")
+ (description
+ "Xpad is a sticky note that strives to be simple, fault tolerant,
+and customizable. Xpad consists of independent pad windows, each is
+basically a text box in which notes can be written.")
+ (license license:gpl3+)))