summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-12-15 12:17:07 +0800
committer宋文武 <iyzsong@gmail.com>2015-12-18 10:30:17 +0800
commit0674b3c96d3aa93b63cdafbf99abe87815aec55c (patch)
treed9cdd8859ddc94ceeeb48aac49323df49f3f4dfc /gnu
parent095da0234299372c9793d1ccd7ee05e5abf0ff04 (diff)
downloadpatches-0674b3c96d3aa93b63cdafbf99abe87815aec55c.tar
patches-0674b3c96d3aa93b63cdafbf99abe87815aec55c.tar.gz
gnu: Add tevent.
* gnu/packages/samba.scm (tevent): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/samba.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 743784c02e..137e04df18 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -25,6 +25,7 @@
#:use-module (gnu packages acl)
#:use-module (gnu packages admin)
#:use-module (gnu packages popt)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages openldap)
#:use-module (gnu packages readline)
#:use-module (gnu packages libunwind)
@@ -203,6 +204,41 @@ Desktops into Active Directory environments using the winbind daemon.")
destructors. It is the core memory allocator used in Samba.")
(license gpl3+))) ;; The bundled "replace" library uses LGPL3.
+(define-public tevent
+ (package
+ (name "tevent")
+ (version "0.9.26")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.samba.org/ftp/tevent/tevent-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1gbh6d2m49j1v2hkaiyrh8bj02i5wxd4hqayzk2g44yyivbi8b16"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ ;; tevent uses a custom configuration script that runs waf.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* "./configure"
+ (string-append "--prefix=" out)
+ "--bundled-libraries=NONE"))))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python" ,python-2)))
+ (propagated-inputs
+ `(("talloc" ,talloc))) ; required by tevent.pc
+ (synopsis "Event system library")
+ (home-page "https://tevent.samba.org/")
+ (description
+ "Tevent is an event system based on the talloc memory management library.
+It is the core event system used in Samba. The low level tevent has support for
+many event types, including timers, signals, and the classic file descriptor events.")
+ (license lgpl3+)))
+
(define-public ppp
(package
(name "ppp")