summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-10-12 12:09:26 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-12 12:13:46 +0200
commit5b811ddc671777780233f23a819054ef62dcbacb (patch)
treea921614f81b88d2065a6e866811e7e86de70019d /gnu
parentbe6f2f5634fc9d3639beb0330a04f4fa21020e64 (diff)
downloadpatches-5b811ddc671777780233f23a819054ef62dcbacb.tar
patches-5b811ddc671777780233f23a819054ef62dcbacb.tar.gz
gnu: emacs-wgrep: Update to 2.3.1.
* gnu/packages/emacs-xyz.scm (emacs-wgrep): Update to 2.3.1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm39
1 files changed, 21 insertions, 18 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5ae3db83cd..a55282a0a9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6601,26 +6601,29 @@ Dust.js, React/JSX, Angularjs, ejs, etc.")
(license license:gpl3+)))
(define-public emacs-wgrep
- (package
- (name "emacs-wgrep")
- (version "2.3.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mhayashi1120/Emacs-wgrep")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0pgyf9vfcahb495q01hi1mvkmv846w4rj6zyf52is8x7sjj7x44s"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/mhayashi1120/Emacs-wgrep")
- (synopsis "Edit a grep buffer and apply those changes to the files")
- (description
- "Emacs wgrep allows you to edit a grep buffer and apply those changes
+ ;; Tag is missing, so we use the commit directly.
+ ;; https://github.com/mhayashi1120/Emacs-wgrep/issues/64
+ (let ((commit "379afd89ebd76f63842c8589127d66096a8bb595"))
+ (package
+ (name "emacs-wgrep")
+ (version "2.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mhayashi1120/Emacs-wgrep")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0v1qx8z1xj9qzirlycbihnkpwcklyi3a0j8lil78pmdpixdbgh47"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mhayashi1120/Emacs-wgrep")
+ (synopsis "Edit a grep buffer and apply those changes to the files")
+ (description
+ "Emacs wgrep allows you to edit a grep buffer and apply those changes
to the file buffer. Several backends are supported beside the classic grep:
ack, ag, helm and pt.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-helm
(package