summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2015-11-05 08:43:44 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2015-11-09 08:31:35 -0500
commit2cbcd23a71c2c394f6bbb949a391a9589c47cf46 (patch)
tree328cd019757311ad51591e3ecce8ebbcc9704177 /gnu
parent60c3627cf67d0f5c477cbb8bacbc9ba8b3ffc437 (diff)
downloadpatches-2cbcd23a71c2c394f6bbb949a391a9589c47cf46.tar
patches-2cbcd23a71c2c394f6bbb949a391a9589c47cf46.tar.gz
gnu: Add ruby-eventmachine.
* gnu/packages/ruby.scm (ruby-eventmachine): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 137b75a24f..3193aeae91 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1649,3 +1649,28 @@ that can be exported to a number of formats very easily, and also supports
extending for custom Ruby constructs such as custom class level definitions.")
(home-page "http://yardoc.org")
(license license:expat)))
+
+(define-public ruby-eventmachine
+ (package
+ (name "ruby-eventmachine")
+ (version "1.0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "eventmachine" version))
+ (sha256
+ (base32
+ "1frvpk3p73xc64qkn0ymll3flvn4xcycq5yx8a43zd3gyzc1ifjp"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; test suite tries to connect to google.com
+ (native-inputs
+ `(("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis "Single-threaded network event framework for Ruby")
+ (description
+ "EventMachine implements a single-threaded engine for arbitrary network
+communications. EventMachine wraps all interactions with sockets, allowing
+programs to concentrate on the implementation of network protocols. It can be
+used to create both network servers and clients.")
+ (home-page "http://rubyeventmachine.com")
+ (license (list license:ruby license:gpl3)))) ; GPLv3 only AFAICT