summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-01 22:14:20 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:25 -0500
commit30eebbe6c341bfafad2124cbb9992e35676933f6 (patch)
treec04caccf7d8900444ae0b357e6a76eb2d4735b07 /gnu
parent97f267c85bd99daca270a17cace3a05775dade5a (diff)
downloadpatches-30eebbe6c341bfafad2124cbb9992e35676933f6.tar
patches-30eebbe6c341bfafad2124cbb9992e35676933f6.tar.gz
gnu: Add ghc-network-bsd.
* gnu/packages/haskell-xyz.scm (ghc-network-bsd): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 100db9a278..d6f5653e89 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6861,6 +6861,27 @@ ncurses.")
"This package provides a low-level networking interface.")
(license license:bsd-3)))
+(define-public ghc-network-bsd
+ (package
+ (name "ghc-network-bsd")
+ (version "2.8.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "network-bsd/network-bsd-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0dfbwgrr28y6ypw7p1ppqg7v746qf14569q4xazj4ahdjw2xkpi5"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-network" ,ghc-network)))
+ (home-page "https://github.com/haskell/network-bsd")
+ (synopsis "POSIX network database (<netdb.h>) API")
+ (description "This package provides Haskell bindings to the the POSIX
+network database (<netdb.h>) API.")
+ (license license:bsd-3)))
+
(define-public ghc-network-info
(package
(name "ghc-network-info")