summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@no-reply.pragmatique.xyz>2017-05-06 00:12:58 +0000
committerLudovic Courtès <ludo@gnu.org>2017-05-06 15:52:25 +0200
commit28a671ed23f82ce7966c04e988a276b38dd8c1e0 (patch)
treeaf7e79b31d1058a56630f98feb6aaf42baee0d01 /gnu
parent5c4ea872247e38371ed9f9c3509ce566eee907b1 (diff)
downloadpatches-28a671ed23f82ce7966c04e988a276b38dd8c1e0.tar
patches-28a671ed23f82ce7966c04e988a276b38dd8c1e0.tar.gz
gnu: fish: Reference 'groff' to fix output of 'fish --help'.
* gnu/packages/shells.scm (fish)[inputs-inputs]: Add 'groff'. [arguments]: Add 'nroff' substitution in 'embed-store-paths' phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/shells.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index d87d58e5c6..4e684e8c81 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -31,6 +31,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages groff)
#:use-module (gnu packages libedit)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pcre)
@@ -116,6 +117,7 @@ direct descendant of NetBSD's Almquist Shell (@command{ash}).")
(inputs
`(("bc" ,bc)
("ncurses" ,ncurses)
+ ("groff" ,groff) ;for 'fish --help'
("pcre2" ,pcre2) ;don't use the bundled PCRE2
("python" ,python-wrapper))) ;for fish_config and manpage completions
(arguments
@@ -133,6 +135,8 @@ direct descendant of NetBSD's Almquist Shell (@command{ash}).")
"/bin/bc")))
(substitute* "share/functions/fish_update_completions.fish"
(("python") (which "python")))
+ (substitute* "share/functions/__fish_print_help.fish"
+ (("nroff") (which "nroff")))
#t)))))
(synopsis "The friendly interactive shell")
(description