summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-04-07 19:21:28 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-07-23 10:29:35 +1000
commit98593f9f51c8f6e3c2208d8443fdf08cf4d633bb (patch)
treee772fee04adedb87fa1ff5ff42fbf91c38f99710 /gnu
parent4ab1644049ad2d1cf7a997dfa910a4d7d646e49f (diff)
downloadpatches-98593f9f51c8f6e3c2208d8443fdf08cf4d633bb.tar
patches-98593f9f51c8f6e3c2208d8443fdf08cf4d633bb.tar.gz
gnu: bcftools: Update to 1.4.1.
* gnu/packages/bioinformatics.scm (bcftools): Update to 1.4.1. [arguments]: Move Makefile modifications from here ... [source]: ... to added patch. Adjust patch for update to 1.4. * gnu/packages/patches/bcftools-fix-makefile.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bioinformatics.scm20
-rw-r--r--gnu/packages/patches/bcftools-fix-makefile.patch33
3 files changed, 41 insertions, 13 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 8d3916e26d..3397216e15 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -522,6 +522,7 @@ dist_patch_DATA = \
%D%/packages/patches/awesome-reproducible-png.patch \
%D%/packages/patches/azr3.patch \
%D%/packages/patches/bash-completion-directories.patch \
+ %D%/packages/patches/bcftools-fix-makefile.patch \
%D%/packages/patches/binutils-ld-new-dtags.patch \
%D%/packages/patches/binutils-loongson-workaround.patch \
%D%/packages/patches/binutils-mips-bash-bug.patch \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f5122a1802..87da4aed15 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -300,7 +300,7 @@ BAM files.")
(define-public bcftools
(package
(name "bcftools")
- (version "1.3.1")
+ (version "1.4.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -308,11 +308,12 @@ BAM files.")
version "/bcftools-" version ".tar.bz2"))
(sha256
(base32
- "095ry68vmz9q5s1scjsa698dhgyvgw5aicz24c19iwfbai07mhqj"))
+ "024xv59bzv148b6w3das4jmldf7rywsf8y1fbqznap008qc8gl6p"))
+ (patches (search-patches "bcftools-fix-makefile.patch"))
(modules '((guix build utils)))
(snippet
;; Delete bundled htslib.
- '(delete-file-recursively "htslib-1.3.1"))))
+ '(delete-file-recursively "htslib-1.4.1"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -321,19 +322,12 @@ BAM files.")
"USE_GPL=1"
(string-append "prefix=" (assoc-ref %outputs "out"))
(string-append "HTSDIR=" (assoc-ref %build-inputs "htslib") "/include")
- (string-append "HTSLIB=" (assoc-ref %build-inputs "htslib") "/lib/libhts.a")
+ (string-append "HTSLIB=" (assoc-ref %build-inputs "htslib") "/lib/libhts.so")
(string-append "BGZIP=" (assoc-ref %build-inputs "htslib") "/bin/bgzip")
- (string-append "TABIX=" (assoc-ref %build-inputs "htslib") "/bin/tabix"))
+ (string-append "TABIX=" (assoc-ref %build-inputs "htslib") "/bin/tabix")
+ (string-append "PACKAGE_VERSION=" ,version))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-Makefile
- (lambda _
- (substitute* "Makefile"
- ;; Do not attempt to build htslib.
- (("^include \\$\\(HTSDIR\\)/htslib\\.mk") "")
- ;; Link against GSL cblas.
- (("-lcblas") "-lgslcblas"))
- #t))
(delete 'configure)
(add-before 'check 'patch-tests
(lambda _
diff --git a/gnu/packages/patches/bcftools-fix-makefile.patch b/gnu/packages/patches/bcftools-fix-makefile.patch
new file mode 100644
index 0000000000..614f5fd6bd
--- /dev/null
+++ b/gnu/packages/patches/bcftools-fix-makefile.patch
@@ -0,0 +1,33 @@
+diff --git a/Makefile b/Makefile
+index edd2c4a..73b25ea 100644
+--- a/Makefile
++++ b/Makefile
+@@ -30,8 +30,8 @@ all: $(PROG) $(TEST_PROG)
+
+ # Adjust $(HTSDIR) to point to your top-level htslib directory
+ HTSDIR = htslib-1.4.1
+-include $(HTSDIR)/htslib.mk
+-include $(HTSDIR)/htslib_static.mk
++#include $(HTSDIR)/htslib.mk
++#include $(HTSDIR)/htslib_static.mk
+ HTSLIB = $(HTSDIR)/libhts.a
+ BGZIP = $(HTSDIR)/bgzip
+ TABIX = $(HTSDIR)/tabix
+@@ -73,7 +73,7 @@ GSL_LIBS =
+ ifdef USE_GPL
+ EXTRA_CPPFLAGS += -DUSE_GPL
+ OBJS += polysomy.o peakfit.o
+- GSL_LIBS = -lgsl -lcblas
++ GSL_LIBS = -lgsl -lgslcblas
+ endif
+
+ prefix = /usr/local
+@@ -217,7 +217,7 @@ test/test-regidx.o: test/test-regidx.c regidx.h
+ test/test-regidx: test/test-regidx.o regidx.o $(HTSLIB)
+ $(CC) $(ALL_LDFLAGS) -o $@ $^ $(HTSLIB) -lpthread $(HTSLIB_LIBS) $(ALL_LIBS)
+
+-bcftools: $(HTSLIB) $(OBJS)
++bcftools: $(OBJS)
+ $(CC) $(ALL_LDFLAGS) -o $@ $(OBJS) $(HTSLIB) -lpthread $(HTSLIB_LIBS) $(GSL_LIBS) $(ALL_LIBS)
+
+ doc/bcftools.1: doc/bcftools.txt