summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-03-18 21:37:37 +0530
committerLeo Famulari <leo@famulari.name>2017-03-19 19:18:06 -0400
commit6fdbd86d0fcda40967e713c4226d19cee991bcd9 (patch)
tree8c250bf70a8cc28df5b62d33a6ac9553f5e02d07 /gnu
parente05fc441cd5528ba6c83b6371c27c1e87dd393e9 (diff)
downloadpatches-6fdbd86d0fcda40967e713c4226d19cee991bcd9.tar
patches-6fdbd86d0fcda40967e713c4226d19cee991bcd9.tar.gz
gnu: Add libircclient.
* gnu/packages/messaging.scm (libircclient): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 7aa7b7bfe5..85c023514e 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2016, 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
+;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1329,4 +1330,36 @@ using ncurses and libmesode, inspired by Irssi.")
(home-page "http://www.profanity.im")
(license license:gpl3+)))
+(define-public libircclient
+ (package
+ (name "libircclient")
+ (version "1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/libircclient/libircclient/"
+ version "/libircclient-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0r60i76jh4drjh2jgp5sx71chagqllmkaq49zv67nrhqwvp9ghw1"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("openssl" ,openssl)))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--libdir="
+ (assoc-ref %outputs "out") "/lib")
+ "--enable-shared"
+ "--enable-ipv6"
+ "--enable-openssl")
+ ;; no test suite
+ #:tests? #f))
+ (home-page "https://www.ulduzsoft.com/libircclient/")
+ (synopsis "Library implementing the client IRC protocol")
+ (description "Libircclient is a library which implements the client IRC
+protocol. It is designed to be small, fast, portable and compatible with the
+RFC standards as well as non-standard but popular features. It can be used for
+building the IRC clients and bots.")
+ (license license:lgpl3+)))
+
;;; messaging.scm ends here