summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSiniša Biđin <sinisa@bidin.eu>2015-08-18 22:40:13 +0200
committerEric Bavier <bavier@member.fsf.org>2015-08-23 16:49:57 -0500
commitc34507d662979a69a0d0738d64e21d4866931b88 (patch)
treea87ea07d2c1a4dd60662a9deca91566563b03c08 /gnu
parent720fb41c6927062794257d78f17e3e825f694c82 (diff)
downloadpatches-c34507d662979a69a0d0738d64e21d4866931b88.tar
patches-c34507d662979a69a0d0738d64e21d4866931b88.tar.gz
gnu: Add ghc-x11-xft.
* gnu/packages/haskell.scm (ghc-x11-xft): New variable. Signed-off-by: Eric Bavier <bavier@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2e44910cbf..4b2b627561 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -18,12 +18,13 @@
(define-module (gnu packages haskell)
#:use-module (ice-9 regex)
- #:use-module ((guix licenses) #:select (bsd-3))
+ #:use-module ((guix licenses) #:select (bsd-3 lgpl2.1))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system haskell)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages perl)
#:use-module (gnu packages compression)
#:use-module (gnu packages elf)
@@ -529,6 +530,34 @@ UTF8 without truncation.")
bindings are a direct translation of the C bindings.")
(license bsd-3)))
+(define-public ghc-x11-xft
+ (package
+ (name "ghc-x11-xft")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/X11-xft/"
+ "X11-xft-" version ".tar.gz"))
+ (sha256
+ (base32 "1lgqb0s2qfwwgbvwxhjbi23rbwamzdi0l0slfr20c3jpcbp3zfjf"))))
+ (propagated-inputs
+ `(("ghc-x11" ,ghc-x11)
+ ("ghc-utf8-string" ,ghc-utf8-string)))
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxft" ,libxft)
+ ("xproto" ,xproto)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/X11-xft")
+ (synopsis "Bindings to Xft")
+ (description
+ "Bindings to the Xft, X Free Type interface library, and some Xrender
+parts.")
+ (license lgpl2.1)))
+
(define-public ghc-zlib
(package
(name "ghc-zlib")