summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-08-20 16:36:25 +0800
committer宋文武 <iyzsong@gmail.com>2015-08-22 13:42:23 +0800
commit4b58d88bcde652e3307fb66d1da4f93dc10ac7a8 (patch)
tree78c079066a149edd4c9e46043b36022f207a0179 /gnu
parentde1d7cbbdcbc76950cadd44300f8f449d1234bf8 (diff)
downloadpatches-4b58d88bcde652e3307fb66d1da4f93dc10ac7a8.tar
patches-4b58d88bcde652e3307fb66d1da4f93dc10ac7a8.tar.gz
gnu: itstool: Wrap with PYTHONPATH.
* gnu/packages/glib.scm (itstool): Change 'propagated-inputs' to 'inputs'. [arguments]: New field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 88c61b676b..cdec3706dd 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -315,10 +315,20 @@ The intltool collection can be used to do these things:
(base32
"0fh34wi52i0qikgvlmrcpf1vx6gc1xqdad4539l4d9hikfsrz45z"))))
(build-system gnu-build-system)
- (propagated-inputs
+ (inputs
`(("libxml2" ,libxml2)
("python2-libxml2" ,python2-libxml2)
("python-2" ,python-2)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after
+ 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/itstool")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH"))))))))))
(home-page "http://www.itstool.org")
(synopsis "Tool to translate XML documents with PO files")
(description