summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTheodoros Foradis <theodoros.for@openmailbox.org>2017-06-22 22:09:55 +0300
committerDanny Milosavljevic <dannym@scratchpost.org>2017-06-24 09:18:56 +0200
commitcbd9568fcd0ac63dad163bc7a2afafdc74333dad (patch)
tree810067566da5cc89cfbb6e2a48d360588f1017d9 /gnu
parent1251c66425d52ed0a489ebc1a2a653614824ea3e (diff)
downloadpatches-cbd9568fcd0ac63dad163bc7a2afafdc74333dad.tar
patches-cbd9568fcd0ac63dad163bc7a2afafdc74333dad.tar.gz
gnu: Add guile-libctl.
* gnu/packages/engineering.scm (guile-libctl): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/engineering.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 3252e986b6..a9b41757d7 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -880,3 +880,28 @@ harmonic inversion — given a discrete-time, finite-length signal that consists
of finitely-many sinusoids (possibly exponentially decaying) in a given bandwidth, it
determines the frequencies, decay constants, amplitudes, and phases of those sinusoids.")
(license license:gpl2+)))
+
+(define-public guile-libctl
+ (package
+ (name "guile-libctl")
+ (version "3.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "http://ab-initio.mit.edu/libctl/libctl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1g7gqybq20jhdnw5vg18bgbj9jz0408gfmjvs8b4xs30pic8pgca"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("fortran" ,gfortran)))
+ (inputs
+ `(("guile" ,guile-2.2)))
+ (home-page "http://ab-initio.mit.edu/wiki/index.php/Libctl")
+ (synopsis "Flexible control files implementation for scientific simulations")
+ (description
+ "Libctl is a Guile-based library implementing flexible control files
+for scientific simulations.")
+ (license license:gpl2+)))