summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-11 11:54:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-11 16:52:41 +0300
commit5edf2f0561e05683c9df3fea8f728b0cecf3a69b (patch)
treeeadd057618babffa6fbd9c227a61cfe807c9ec36 /gnu
parent38e9373b0d668d9e8347e0d6adce218480d41661 (diff)
downloadpatches-5edf2f0561e05683c9df3fea8f728b0cecf3a69b.tar
patches-5edf2f0561e05683c9df3fea8f728b0cecf3a69b.tar.gz
gnu: grue-hunter: Adapt to gzip-1.8 update.
* gnu/packages/games.scm (grue-hunter)[arguments]: Change gunzip call to gzip call, add `-d' to the gzip command.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 39fc6f2666..6036ce3e19 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
+;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2016 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
@@ -20,7 +21,7 @@
;;; Copyright © 2016 Albin Söderqvist <albin@fripost.org>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il"
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2361,9 +2362,9 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
(perl (string-append (assoc-ref %build-inputs
"perl")
"/bin"))
- (gunzip (string-append (assoc-ref %build-inputs
+ (gzip (string-append (assoc-ref %build-inputs
"gzip")
- "/bin/gunzip"))
+ "/bin/gzip"))
(tar (string-append (assoc-ref %build-inputs
"tar")
"/bin/tar"))
@@ -2373,7 +2374,7 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
(begin
(mkdir out)
(copy-file tarball "grue-hunter.tar.gz")
- (zero? (system* gunzip "grue-hunter.tar.gz"))
+ (zero? (system* gzip "-d" "grue-hunter.tar.gz"))
(zero? (system* tar "xvf" "grue-hunter.tar"))
(mkdir-p bin)