summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-06-14 23:33:17 +0200
committerAndreas Enge <andreas@enge.fr>2013-06-14 23:33:17 +0200
commit4b9adff901e6bb6ef9e631df305a38668e22bd27 (patch)
tree89f4c9bc8bc1e585214accf8ae6d47c48e801c90 /gnu
parenta2609b41b9167a648d0c9c0a01320c7cb5ebe8e1 (diff)
downloadpatches-4b9adff901e6bb6ef9e631df305a38668e22bd27.tar
patches-4b9adff901e6bb6ef9e631df305a38668e22bd27.tar.gz
gnu: Add pango.
* gnu/packages/gtk.scm (pango): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 64f9512715..38ad05e074 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -128,3 +128,28 @@ affine transformation (scale, rotation, shear, etc.)")
(license (license:x11-style "file://COPYING"
"See 'COPYING' in the distribution."))
(home-page "http://www.freedesktop.org/wiki/Software/HarfBuzz/")))
+
+(define-public pango
+ (package
+ (name "pango")
+ (version "1.34.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/pango/1.34/pango-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0k7662qix7zzh7mf6ikdj594n8jpbfm25z8swz64zbm86kgk1shs"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("cairo" ,cairo)
+ ("harfbuzz" ,harfbuzz)
+ ("pkg-config" ,pkg-config)
+ ("zlib" ,zlib)))
+ (synopsis "GNOME text and font handling library")
+ (description
+ "Pango is the core text and font handling library used in GNOME
+applications. It has extensive support for the different writing systems
+used throughout the world.")
+ (license license:lgpl2.0+)
+ (home-page "https://developer.gnome.org/pango/")))